Direkt zum Hauptbereich

Moving FAST Search Server Indexfiles

Ich stand die Tage vor einem Problem mit den Indexfiles des FAST Search Server for SharePoint 2010. Standardmäßig werden die Indexfiles in dem Installationsverzeichnis (C:\FASTSEARCH) abgelegt, der Sinn hiervon sei mal dahingestellt. 
Nach einigen Recherchen bin ich dann auf den folgenden Artikel gestoßen. Die Informationsquellen für die FAST Search sind doch noch relativ dürftig. Die Nomenklatur des mklink-Aufrufes geht aus dem Artikel leider nicht eindeutig hervor und man könnte annehmen, dass man Ihn so übernehmen kann. Ein Junction Point lässt sich auch erfolgreich anlegen, jedoch funktioniert die FAST Search danach nicht mehr.
Hier dann noch einmal der komplette Vorgang mit der einzusetzenden Schreibweise:


  1. Stoppe den FAST Search for SharePoint service
  2. Stoppe den FAST Search for SharePoint Monitoring service
  3. Verschiebe den Ordner C:\FASTSEARCH\data in das neu erstellte Verzeichnis (hier D:\IndexFAST\data)
  4. Starte das folgende Skript in der Konsole: 
    • mklink /j C:\FASTSEARCH\data D:\IndexFAST\data
  5. Starte den FAST Search for SharePoint Service, der Monitoring Service wird automatisch mitgestartet
Dann viel Spaß beim Verschieben der Indexfiles.

Viele Grüße
Patrick




Kommentare

Beliebte Posts aus diesem Blog

Nutzung der Mehrsprachigkeit in SharePoint 2013

Heute wollte ich mich mit dem Thema <Mehrsprachigkeit und SharePoint 2013> auseinandersetzen. Wie in SharePoint 2010 bietet Microsoft auch diverse Sprachpakete für SharePoint 2013 an. Zum heutigen Zeitpunkt stehen Sie leider noch nicht zum freien Download bereit. Wenn Ihr jedoch eine MSDN-Subscription besitzt, so könnt Ihr die verfügbaren Sprachpakete hier herunterladen. Die folgenden Sprachpakete stehen derzeit zum Download bereit.




















Nachdem ich mir die Pakete installiert und den Config-Wizard laufen gelassen habe (Es hat keine 10 Minuten gedauert, das sieht mir nach Optimierung aus) stehen die Pakete zur Verfügung und ich kann Sie auf den einzelnen Site-Collections aktivieren. Dazu gehe ich wie gewohnt in die <Site-Settings>








und wähle dort die <Language settings> aus und markiere die gewünschte Sprache.


























Das sind alles keine Änderungen gegenüber SharePoint 2010. Meine Seite öffnet sich nun wie erwartet in Deutsch. Nun möchte ich jedoch wieder in die englische Sprache …

Benutzer einer SharePoint-Gruppe auslesen (Data One Power Activity for Nintex Workflow)

Ich habe dieser Tage ein kleines Problem mit der Nintex-Aktivität << Data Request >> gehabt. Derzeit ist es leider nur möglich dieser Aktivität einen Benutzer zuzuweisen. Was nun aber tun, wenn mehrere Benutzer diese Dateneingabe vornehmen sollen. Man kann das Ganze umgehen, indem man eine neue SharePoint-Gruppe anlegt und die Benutzer in dieser Gruppe einpflegt.
Hier bin ich dann jedoch auf das nächste Problem gestoßen. Die SharePoint-Gruppe wird nicht aufgelöst, so dass die Aufgabe nicht in den Nintex-Webpart << Meine Workflowaufgaben >> angezeigt wird. Ich habe mir nun Gedanken über eine mögliche Lösung gemacht und bin zu folgendem Ergebnis gekommen.

Schritt 1: SharePoint Webservice
Auslesen der SharePoint-Gruppe mit dem SharePoint Webservice (http://sharepoint/_vti_bin/UserGroup.asmx) und der Methode << GetUserCollectionFromGroup >>. Als Ergebnis bekommen wir folgendes XML-Konstrukt (aus Darstellungsgründen habe ich es auf den LoginName beschränk…

Aktivierung Blob Cache (Enable Blob Cache SharePoint 2013)

Heute wollte ich mich mit der neuen Funktionalität der <Image Renditions> (Bildwiedergabe) im SharePoint Server 2013 beschäftigen. Man kann den Punkt <Image Renditions> in den Site-Settings finden. Bevor ich nun jedoch Einstellungen und die Funktionalität nutzen kann erwartete mich zunächst eine Warnmeldung:

"The blob cache is not enabled in this web application. Image Renditions will not be generated until the blob cache is enabled. For information on turning on the blob cache, please review the product information."







Ich habe mich dann einmal in der Zentraladministration auf die Suche nach Einstellungen auf Webanwendungsebene für die Aktivierung des Blob Cache gemacht, bin in der GUI jedoch nicht fündig geworden. Was nun tun? Gibt es eventuell PowerShell cmdlets für SharePoint 2013 zum Aktivieren des Blob Cache. Auch hier bin ich leider nicht fündig geworden. Aber da es sich um Konfigurationseinstellungen der Webanwendung handelt so findet man diese doch bestimm…